terça-feira, 19 de agosto de 2008

Configurando o autocompletar do eclipse

Estava utilizando o eclipse e de repente percebi que o autocompletar tinha perdido a funcionalidade. Procurei na internet e nada de achar uma solução. Então um amigo conseguiu solucionar o problema e resolvi postar a solução aqui.

1 - Para configurar o autocompletar vá em:
Window - Preferences

2 - Nessa janela selecione a opção:
Java - Editor - Advanced

3 - Marque os quatro primeiros checkboxes das duas áreas que aparecerão na tela (parte superior e inferior) e clique em OK.


A imagem acima mostra a área de configuração. Clique nela para ver detalhes.

Pronto, o autocompletar está funcionando!

21 comentários:

Fabi disse...

Valeu demais pela dica!!!
O meu auto completar também parou de funcionar do nada!!!
Procurei e não encontrei o problema, reinstalei o eclipse e a JDK e não resolveu!
Foi só setar a configuração q vc sugeriu e o problema foi resolvido!
MUITO OBRIGADA, mesmo!!!
Abraços,

sis0501 disse...

Nossa, o meu Eclipse parou de autocompletar também e eu perdi um tempão procurando solução...
Valeu mesmo pelo post, me ajudou pra caramba!!!

Daniel Gondim disse...

Cara, brigadão!
vc eh foda

Wagner A. e Silva disse...

Valeu :)
Estou trabalhando com o android e já estava louco sem o auto completar...

Andreza disse...

Nossa, eu nem tinha mais esperanças, e funcionou mesmo!!!
Muito obrigada!

RR disse...

Muitíssimo obrigado!!!
Já estou a tempos procurando, quase que sem esperança.
Ganhei o dia, com certeza! :D

Obrigado e parabéns pela iniciativa de compartilhar!!

Abraços!

Roberto disse...

ow, valeu mesmo!

ajudou aqui.

123 Web Programação disse...

Muito bom!! Voce é o cara

Tales disse...

Valeu Cara, meu eclipse tava todo quebrado. Tentei reinstalar, exclui arquivos de configuração e nada... Já tava desesperado.

Lucas Daniel disse...

obrigado amigo, já tinha feito tanta coisa e nada funcionava!!

Unknown disse...

Valeu, funcionou mesmo, me salvou, tava sem saber o que fazer

MARKHOS disse...

Meu Brother salvo aqui tbm estava louco aqui ja, digitando tudo na unha.
Pessoas como vc fazem a diferença.

RicardoSP disse...
Este comentário foi removido pelo autor.
RicardoSP disse...

Oi...
...acho que sou o primeiro a postar uma resposta negativa por aqui.

Fiz exatamente isso no Eclipse Indigo, mas não funcionou.

No meu caso, uso o Eclipse para programar em C para µCs, mas trocando o caminho do "Java" por "C/C++", é o mesmo caminho.

Cássio Nandi Citadin disse...

A dica funcionou. Muito obrigado!

Rodrigo disse...

Ah mlk Bom D+
VALEW

Wagner Souza disse...

muito obrigado pela dica que Deus te abençoe

Wagner Souza disse...

muito obrigado que Deus te abençoe

Unknown disse...

Voce é o cara!

Rodrigo Coutinho disse...

Salvou minha vida.. tava ficando doido já.. obrigado pelo post!

Adriano Nascimento Martins disse...

Valeu cara, realmente depois de muito tentar e pesquisar, foi o único que resolveu o problema, obrigado e parabéns pela iniciativa.